Errors with Account Creation

Incident Report for Cloudinary

Resolved

The recent sign-up issue has been resolved. All services are now operating normally.
Posted Mar 19, 2026 - 14:38 EDT

Monitoring

A fix for this issue has been deployed, and we are currently monitoring the results.
Posted Mar 19, 2026 - 13:13 EDT

Investigating

We're currently investigating a reported issue when users are attempting to sign up. Our engineering team is working to restore normal operation, and we will provide further updates shortly.
Posted Mar 19, 2026 - 12:48 EDT
This incident affected: Management Console.